Glowstone Lanterns

Glowstone Lanterns Icon

Make glowstone lanterns, daytime glass & nighttime glowstone

Version: v1.0.1

Glowstone Lanterns

With this plugin Glowstone Lanterns you can make lanterns, when it's going dark the glass of the lanterns will change in glowstone and when it's daytime it will change in glass again. The great thing is that you don't need to place a full lantern but only a glass/glowstone block, so you can use it for everyting. This plugin is very usefull for a large city to light it up, that looks really cool that the lanterns will change in glowstone! You can also place prebuilt lanterns, so that's really usefull if you want to plase a lot of lanterns in a little time. You can enable glowstone lanterns with /gl, when you place a glass or a glowstone block it is marked as a glowstone lanterns, this block will change to glowstone if it is night and to glass if it is daytime. If you use /gl l 1 you will enable prebuilt glowstone lanterns, if you place a glass or a glowstone block there will apear the prebuilt glowstone lantern you selected right there. There prebuilt lanterns are in external files, so you can make your own prebuilt lanterns and share them with other pelople.

Video

In this video you can see how the plugin works: (Outdated Video)

Features

  • Permissions support
  • Multi world support
  • Place prebuilt lanterns that are located in external files, you can make them and share them with other pelople
  • Possibility to create your own lanterns
  • Players can only destroy lanterns if he have permission
  • And a lot more!

Upcoming features

  • Custommessages and color support
  • In-game prebuilt lanterns creator

Player Commands

ActionCommandPermission node
Enable build mode/glglowstonelanterns.gl
/glowstonelantern
/glowstonelanterns
Enable prebuilt mode/gl lantern <name>glowstonelanterns.gl
/gl l <name>
Disable prebuilt mode/gl lantern
/gl l
List prebuilt lanterns/gl list lanterns
/gl list l
View help/gl help
View info/gl infoglowstonelanterns.info
Save lanterns/gl saveglowstonelanterns.save
Reload lanterns/gl reloadglowstonelanterns.reload
Check current version/gl version

Please go to the original page to find more information.

Download

You could download Glowstone Lanterns with the link on the top-right of this page above the sidebar.

Installation

1. Download the plugin 2. Add the GlowstoneLanterns.jar file and the folder 'Glowstone Lanterns' from the downloaded .zip file to the /plugin folder of the Minecraft server. Also add the included folder 'Glowstone Lanterns' to your plugins folder. 3. Add the permissions if you have; (Look at the permissions paragraph underneath) 4. Start your game and use Glowstone Lanterns!

Permissions

ActionPermission nodeDefault
/gl commandglowstonelanterns.glOperators
Destroy lanternsglowstonelanterns.destroyLanternsOperators
Info commandglowstonelanterns.infoOperators
Save commandglowstonelanterns.saveOperators
Reload commandglowstonelanterns.reloadOperators

How to make your own prebuilt lantern

You could find the guide for this on the following page:

Page: Tutorials : How to create your own prebuilt lanterns

Suggestions, Ideas and bugs

I've you have any suggestion, ideas or bugs found. Please reply on this page or create a ticket.

Donate

Please donate some money so I can buy some coffee to make better plugins, I really like it if you give a donation! Donate

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of timvisee timvisee Apr 11, 2016 at 15:10 UTC - 0 likes

    Glowstone Lanterns 1.0.1 / Minecraft 1.9.2

    Glowstone Lanterns 1.0.1 has just been released. This is a small update that includes Minecraft 1.9.2 support and an updated bPermissions library.

    Please note that this version is made for Minecraft 1.9 (using CraftBukkit for Minecraft 1.8 or lower might not work). This version also requires Java 1.8 to be installed on the server's system.

    The update is currently under review by the Bukkit administrators, and will be available here as soon as it has been accepted:
    Download file (Download page)

    Changelog:

    • Added support for Minecraft 1.9.2.
    • Updated bPermissions library.
    • Build against Bukkit-1.9-R0.1 with Java 1.8.

    Safe Creeper World Portal

  • Avatar of timvisee timvisee Mar 08, 2016 at 16:48 UTC - 0 likes

    @jeffjones33: Go

    That is awesome, good to hear!

  • Avatar of jeffjones33 jeffjones33 Mar 08, 2016 at 16:05 UTC - 0 likes

    @jeffjones33: Go

    It works great! May thanks.

  • Avatar of timvisee timvisee Mar 08, 2016 at 14:38 UTC - 0 likes

    Update for Minecraft 1.9 / Bukkit 1.9 R0.1

    I've updated the Glowstone Lanterns project to make it compatible with the latest released Bukkit version for Minecraft 1.9.

    This update has some minor changes and fixes for compatibility. The permissions handling has been improved for better support and a better experience. All the permission system API's have been updated accordingly.

    It's important to note that the name of the plugin has been changed. It's a minor change, but this might require server administrators with custom server managers to update some things. Previously, the name of the plugin (as read by the Bukkit server) contained a whitespace, this has now been removed. The data directory of GlowsoneLanterns has just been changed accordingly. The new version of GlowstoneLanterns will automatically move the old data directory to it's new location if available when the plugin is started. If this is the first time you're installing the plugin, you can ignore this notice and you're all set!

    Please note that this version is made for Minecraft 1.9 (using CraftBukkit for Minecraft 1.8 or lower might not work). This version also requires Java 1.8 to be installed on the server's system.

    The update is currently under review by the Bukkit administrators, and will be available here as soon as it has been accepted:
    http://dev.bukkit.org/bukkit-plugins/glowstone-lanterns/files/4-glowstone-lanterns-0-8/

    Changelog:

    • Added support for Minecraft 1.9.
    • Updated all permissions system API's to their latest versions.
    • Improved permissions system handling in general.
    • Moved data directory (removed whitespace), data directories from earlier versions will be moved and updated automatically.
    • Removed whitespace from plugin name.
    • Fixed errors when running commands from the console.
    • Fixed various other bugs.
    • Build against Bukkit-1.9-R0.1 with Java 1.8.

    Tim Visée

    Last edited Mar 08, 2016 by timvisee
  • Avatar of jeffjones33 jeffjones33 Mar 08, 2016 at 11:40 UTC - 1 like

    @timvisee: Go

    That is too cool! Thanks

  • Avatar of timvisee timvisee Mar 08, 2016 at 10:38 UTC - 0 likes

    @jeffjones33: Go

    That's not a problem! The plugin had quite a simple setup, which allows me to test it fairly easily. I might have a working build (for Minecraft 1.9) available in a few hours. I'll release a cleaned version, with better command handling and things like an automatic updater later on.

    Tim Visée

  • Avatar of jeffjones33 jeffjones33 Mar 08, 2016 at 09:32 UTC - 0 likes

    @timvisee: Go

    The last time I tried it I don't really remember seeing any errors. you could run the /gl commands but nothing would happen. I think there may have been in the console but I can't remember what. Sorry. I can give it a try once I get home today

  • Avatar of timvisee timvisee Mar 08, 2016 at 08:02 UTC - 0 likes

    @jeffjones33: Go

    Hello,

    Thanks, thats quite a long time! Awesome to still see people using it since I didn't update it for so long, it was one of my first plugins too.

    But yeah, I'll update the plugin to make it compatible with Minecraft 1.9!

    I would like to ask, do you know about any notable bug I have to fix for this release?

    Tim Visée

  • Avatar of jeffjones33 jeffjones33 Mar 08, 2016 at 07:55 UTC - 0 likes

    @timvisee: Go

    Thanks timvisee! If you could the 1.9 version would be the best. I love this plugin and have benn using it since Minecraft 1.3.2

    :-)

  • Avatar of timvisee timvisee Mar 07, 2016 at 23:08 UTC - 0 likes

    @jeffjones33: Go

    Hello,

    Would you indeed like to have an update that is compatible with the latest Minecraft version?

    If so, I'll try to release an update to fix the issues that occur when using this plugin with Minecraft 1.8 and 1.9.

    Would you like to see a version for Minecraft 1.8 or Minecraft 1.9?

    Tim Visée

Do you like the Glowstone Lanterns plugin?

  1. Choice:

  1. Results
  2. 2 comments

Facts

Date created
Mar 06, 2012
Categories
Last update
Apr 11, 2016
Development stage
Release
Language
  • enUS
License
All Rights Reserved
Curse link
Glowstone Lanterns
Downloads
12,419
Recent files

Authors