GeoIP database library for Bukkit.


  • Supports the GeoIPCountry, GeoIPCity and GeoIPv6 databases.
  • Databases are downloaded automatically and auto updated.
  • Auto update can be disabled or delayed (in days).
  • Databases are only loaded when a plugin requests it.
  • The user can specify from where the databases will be downloaded.
  • The user can specify a path to his own database files (download and auto update feature will be disabled in this case).
  • Permissions via SuperPerms (Bukkit inbuilt permissions).
  • Anonymous statistic reporting to

Development builds of this project can be acquired at the provided continuous integration server. These builds have not been approved by the BukkitDev staff. Use them at your own risk. - Dev Builds

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Finelarme2 Finelarme2 Jan 11, 2014 at 11:25 UTC - 0 likes

    Ok thanks in advance for the update. I wait that so much.

  • Avatar of Fishrock123 Fishrock123 Dec 30, 2013 at 06:36 UTC - 0 likes

    @ryan_the_leach: Go


    I'll try to check GeoIPTools against the 1.7 beta build tomorrow.

  • Avatar of ryan_the_leach ryan_the_leach Dec 17, 2013 at 15:18 UTC - 0 likes

    I've updated this to fix a bug and submitted it to fishrocks github account.

    download at your own risk or compile it, never trust plugins not hosted on

    Link Removed

    Last edited Dec 18, 2013 by lDucks
  • Avatar of chsedv chsedv Dec 11, 2013 at 07:41 UTC - 0 likes

    pls update to bukkit 1.7.2

  • Avatar of ferrybig ferrybig Mar 29, 2013 at 11:10 UTC - 0 likes

    actually you should say it support superperm, not permissionsbukkit

    permissionsbukkit = first superperm compactable plugin

    superperm = bukkit inbuild permissions

    This user has removed his signature ( :-P )

  • Avatar of Fishrock123 Fishrock123 Mar 23, 2013 at 16:33 UTC - 1 like

    @tiagoomendess: Go

    Maybe? Probably? You'll have to just try it.

    @EvilJackCarver: Go

    I already know that, and I don't care. People should go use bPerms or something that is made by sane people.

    Last edited Mar 23, 2013 by Fishrock123
  • Avatar of tiagoomendess tiagoomendess Mar 23, 2013 at 16:06 UTC - 0 likes

    It work with Groupmanager?

  • Avatar of EvilJackCarver EvilJackCarver Mar 23, 2013 at 15:01 UTC - 0 likes

    @Fishrock123: Go

    Just a heads-up, Pex doesn't support inbuilt bukkit methods.

  • Avatar of Fishrock123 Fishrock123 Mar 20, 2013 at 14:36 UTC - 0 likes

    @bad339: Go

    It should work with any permission plugin that uses the inbuilt bukkit permission methods.

  • Avatar of bad339 bad339 Mar 20, 2013 at 00:35 UTC - 0 likes

    Can you make this support PEX please?

Table of contents

  1. 1 GeoIPTools


Date created
Aug 29, 2011
Last update
Mar 08, 2013
Development stage
  • enUS
Apache License version 2.0
Curse link
Recent files



Optional dependency