FramePicture

Banner

MainCommandsPermissionsSourceChange-LogHomepage

What is FramePicture?

FramePicture is a Plugin, who can show Pictures in your Frames.

-> How to install

1. Download the newest FramePicture.jar
2. Download the newest ProtocolLib from http://dev.bukkit.org/bukkit-plugins/protocollib/
3. Stop your Server
4. Drop the FramePicture.jar into your plugins folder.
5. Drop the ProtocolLib.jar into your plugins folder.
6. Start your Server
7. See the Tutorial

-> Tutorial

1. Install the Plugin and ProtocolLib.
2. Join to your Server.
3. Set a Frame
4. Search a photo for the frame
5. Type "/fp set URL" in the chat
6. Click on a item frame entity
7. Finish!

-> Supported file formats

FramePicture supports the File Formats .gif (no animations), .png and .jpg.

-> Multilanguage

This Plugin supports Multilanguage.
message.yml Downloads: English (Standard), Deutsch, France (by cocoman37), Czech (by jaraxxx), Portuguese (by LCastr0), Polish (by Alsiokowsky), Spanish (by jaime29010), Dutch (by Jhtzb), Russian (by Igor1998), Danish (by fungreenfox)
You can make Translates and send me the messages.yml!

-> Video

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of ChiTownSounds ChiTownSounds Sep 01, 2014 at 10:28 UTC - 0 likes

    I LOVE this plugin! I'm hoping to keep it, but if I do, there are a couple things I need to figure out.

    1st: My sign at /spawn stays... but It will randomly lose one or two of the frames in the row of 5. I can't tell what does it exactly. Recently, a player shot a flaming arrow at it, the two frames he hit, de-spawned. I have not been present to see what makes them continue to de-spawn tho.

    2nd: Signs OUTSIDE of spawn don't stay once you have left the chunk. I saw in the github files, something about chunks. Is there a setting to A: Keep the picture loaded even when you leave the chunk? or B: keep the whole CHUNK loaded? This is my BIGGEST problem right now as these signs show RANKS.

    3rd: In my new RANKS area, I have set 8 images. When it was only 4, there were no lag problems. Then I added 4 more, but very small, images and now when I /warp in, even tho the images are NOT showing, I get a MAJOR lag spike! Is that too many images? Is there a way to make those images LOCAL and still use them?

    Here is an image of part of my setup... this is two of the 4 elemental rank areas...

    http://imgur.com/e5Yarxm.png

    Any tips you could give me for my problems would be appreciated it! Thanks... and GREAT work!

    Last edited Sep 01, 2014 by ChiTownSounds: forgot a word & misspelling
  • Avatar of googlebuscus googlebuscus Sep 01, 2014 at 04:24 UTC - 0 likes

    Why doesn't this support Spigot?

  • Avatar of Limeth Limeth Aug 31, 2014 at 16:21 UTC - 0 likes

    @BartkooPL: Go

    People remove them, that's why. We need a permission for it.

    I'm learning. Sorry for my bad grammar.

  • Avatar of BartkooPL BartkooPL Aug 29, 2014 at 19:57 UTC - 0 likes

    1.7.2 after restart client/server picture disappear :(

  • Avatar of SXRWahrheit SXRWahrheit Aug 29, 2014 at 16:25 UTC - 0 likes

    Still has issues of lag when loading into the area. :(

    http://summaxr.com/newgtop.gif
    I run http://summaxr.com and our Minecraft server at mc.summaxr.com - feel free to visit.

  • Avatar of Limeth Limeth Aug 26, 2014 at 09:20 UTC - 0 likes

    Add a permission for removing the frames, please. (in tickets)

  • Avatar of Skrittlez Skrittlez Aug 22, 2014 at 18:48 UTC - 0 likes
    Hello, I really like the plugin, but the main thing is that I hope you can update on when the server restarts, the pictures can disappear.
  • Avatar of robotnikthingy robotnikthingy Aug 18, 2014 at 15:25 UTC - 1 like

    There is a bug which occurs when the server restarts the frame-pictures become blank. Reloading the plugin fixes this, but then the server crashes a few seconds after reloading the plugin

    here is the crash log

    http://pastebin.com/ujZKL77Z

    BFAK:90691927,07571dc2c72cb17766fe413c26d50bbbee919222c04d99b88bcb407f992b3c11

  • Avatar of bilybobby bilybobby Aug 17, 2014 at 22:31 UTC - 0 likes

    <<reply 2313126>>

    Hello, thanks I guess I overlooked that part.

    I have installed it and it works now!  So thank you.

    Next question...

    For some reason the picture disappears after each server restart, is there a way to get passed this in the config file?  Also is there a away for people to not be able to mess with the picture if it is in spawn protection zone?  If they hit it it goes away.

    P.S. I remade the picture, and then I went to the nether and came back and picture was gone.

    Last edited Aug 18, 2014 by bilybobby
  • Avatar of Howaner Howaner Aug 17, 2014 at 11:36 UTC - 1 like

    @bilybobby: Go

    The new build requires ProtocolLib.
    Have you ProtocolLib installed?

Facts

Date created
Feb 05, 2013
Categories
Last update
Aug 13, 2014
Development stage
Release
Language
  • deDE
  • enUS
  • frFR
  • koKR
License
GNU General Public License version 2 (GPLv2)
Curse link
FramePicture
Downloads
39,108
Recent files

Authors

Relationships

Required dependency
ProtocolLib
Optional dependency
Vault
WorldGuard