EndlessEnchant

This basically does what the title says, it allows you to enchant any item with any enchantment with no max level limits, for example, you could enchant a sword to have 30,000 of every enchantment or a weapon, the possibilities are endless with Endless Enchant.

Videos:

English by GamingJuts

Portuguese by AbsintoJ

Permissions:
  • EndlessEnchant.use -> Allows you to access the "/ee" command.
  • EndlessEnchant.level.x -> Sets the max enchantment level. (Replace "x" with a number)
Old Permissions (Removed in 1.5):
  • EndlessEnchant.level.bypass -> Allows you to enchant over the max level. (default: 10)
Features:
  • Enchant any item.
  • Enchant with no level limits.
  • Enchant with every enchantment.
  • You can specify the enchantment name or number.
  • You can use the word "all" to enchant with all enchantments.
  • You can change the messages. (Great for translation)
  • NEW You can now disable negative enchantments. (Enabled by default)
  • NEW You can now have more roman numeral levels. (Enabled by default)
Notes:

As of right now, the only permission plugins that are supported are PermissionsEx, GroupManager, bPermissions, and Bukkit's built in permissions. If you would like your permission plugin supported, let me know and I may consider adding it.

Please do not ask for an update without actually testing the plugin to see if it works on your server.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Paulpkyou Paulpkyou Oct 28, 2013 at 18:16 UTC - 0 likes

    @tonylcc1995: Go

    Sorry for the late response, as Drkmaster83 pointed out, you are in fact using his version of the plugin. My plugin works within the bounds of the API so If Bukkit updates my plugin will continue to work.

    Last edited Oct 28, 2013 by Paulpkyou

  • Avatar of Drkmaster83 Drkmaster83 Oct 13, 2013 at 19:29 UTC - 0 likes

    @tonylcc1995: Go

    I believe that you may be using my version of the plugin, as this plugin does not use "org/bukkit/craftbukkit/v1_6_R2/inventory/CraftItemStack," which is what caused the error. If you are using my plugin, I've decided against making a build for 1.6.4 until there's either a beta or release, but chances are that 1.7 will be out before that, which is why there might not be a 1.6.4 build.

    BFAK:90721119,8cf76d99f6021529905838e18dfa48449eedc1dc549ea1c67b4709589cb3d2e5

  • Avatar of tonylcc1995 tonylcc1995 Sep 26, 2013 at 10:52 UTC - 0 likes

    unlucky, it is not working in 1.6.4, sad.....

    Could not load 'plugins\EndlessEnchant.jar' in folder 'plugins' 26/9/2013 18:46:14 org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/v1_6_R2/inventory/CraftItemStack 26/9/2013 18:46:14 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184) 26/9/2013 18:46:14 at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305) 26/9/2013 18:46:15 at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230) 26/9/2013 18:46:15 at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:239) 26/9/2013 18:46:15 at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:217) 26/9/2013 18:46:15 at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56) 26/9/2013 18:46:15 at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11) 26/9/2013 18:46:15 at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107) 26/9/2013 18:46:15 at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393) 26/9/2013 18:46:15 at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583) 26/9/2013 18:46:15 Caused by: java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/v1_6_R2/inventory/CraftItemStack 26/9/2013 18:46:15 at java.lang.Class.forName0(Native Method) 26/9/2013 18:46:15 at java.lang.Class.forName(Class.java:270) 26/9/2013 18:46:15 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173) 26/9/2013 18:46:15 ... 9 more 26/9/2013 18:46:15 Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.v1_6_R2.inventory.CraftItemStack 26/9/2013 18:46:15 at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:70) 26/9/2013 18:46:15 at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53) 26/9/2013 18:46:15 at java.lang.ClassLoader.loadClass(ClassLoader.java:424) 26/9/2013 18:46:15 at java.lang.ClassLoader.loadClass(ClassLoader.java:357) 26/9/2013 18:46:15 ... 12 more

  • Avatar of RoonsterMan02 RoonsterMan02 Sep 15, 2013 at 18:39 UTC - 0 likes

    its a PLUGIN

  • Avatar of twetwetwetwe twetwetwetwe Sep 10, 2013 at 20:39 UTC - 0 likes

    verry good mod

  • Avatar of RoonsterMan02 RoonsterMan02 Aug 20, 2013 at 17:19 UTC - 0 likes

    Im going to make a diamond scuba mask!

  • Avatar of Paulpkyou Paulpkyou Aug 17, 2013 at 20:59 UTC - 0 likes

    Hey everyone, sorry for not responding in a while, I see a lot of you are posting about updates and issues so let me clear some things up.

    ERRORS

    If you are getting errors from the plugin and somewhere in the error message you see "UnsupportedClassVersionError", this means that you need to update java due to the plugin being compiled with a newer version of java than the one you have. If you have a different error, post it and I'll see what I can do.

    UPDATES

    This plugin is up to date. Despite what the version says, it will always work with the latest build of Bukkit since it is only using functions from within the API. If the plugin one day seems to break due to some unknown reason, I will update it and fix it. Other than that, the only time I plan to do an update is to add new features.

    I hope this helps answer future questions, Thanks for all of your support. :)

    Last edited Aug 17, 2013 by Paulpkyou
  • Avatar of astronautlevel astronautlevel Jul 16, 2013 at 17:39 UTC - 0 likes

    No error is thrown in 1.6.2 Everything seems working just fine. Nice plugin!

  • Avatar of Drkmaster83 Drkmaster83 Jul 11, 2013 at 05:36 UTC - 0 likes

    @JordanMassey99: Go

    This means that the plugin was compiled with [a java version different from your server] Java 7 and you aren't using Java 7 for running your server.

    @rpr797: Go

    Post it for the author?

  • Avatar of rpr797 rpr797 Jul 10, 2013 at 20:10 UTC - 0 likes

    I get an error in 1.6 as well.

Facts

Date created
Jan 20, 2013
Categories
Last update
Feb 05, 2016
Development stage
Release
Language
  • enUS
License
All Rights Reserved
Curse link
EndlessEnchant
Downloads
74,597
Recent files

Authors