ChestShop (iConomyChestShop)

ChestShop logo - mini

(VERSION 3.7.11-DEV) 1.7.8 DEV VERSION IS AVAILABLE HERE. WARNING - SHOPS WILL BE UNUSABLE UNTIL THEIR OWNER CONNECTS TO THE SERVER AT LEAST ONCE

I WILL BE OFFLINE FROM 23rd TO 30th APRIL

ChestShop

A simple, yet very powerful system for making physical shops using signs and chests.

It's never been that easy to create shops! With features like shop protection and anti-lag protection, you won't have to worry about your server's economy anymore!

"Just works"! Don't worry about your economy plugin, ChestShop supports all of them - iConomy, BOSEconomy and more - you need Vault to use other economy plugins).

The plugin by default submits anonymous stats about your server (player count, plugin/server version and type) to a public statistics website - mcstats.org - in order to provide the developers with usage information. If you wish to opt out, you can do so in the PluginMetrics/config.yml file. It also features an auto-update feature, which can be turned off in the config.

Additional modules for ChestShop:

Using shops

It's easy! Just right-click the sign to buy, left-click to sell. (You can configure the buttons in the config file!)

How to create a shop

Player shop

Place a chest on the ground
Place a sign 1 block away from the chest (for example, above it)
On the sign, write:Sign
First line will be filled by the plugin automatically
Price line is a combination of buy and sell prices. You need to have a price indicator (like 'B' - price that will apply to items BOUGHT by PLAYERS - or 'S' - the SELL price) near the price - the prices are separated by a colon (:)Some of the possible price combinations: "B 5:5 S", "B 5", "S free"
You can find out the name of the item you're holding by doing /iteminfo
For exampleExample sign
A person can buy 64 diamonds for 10 dollars and sell them back for 5 dollars from AcrobotPL

Admin Shop - shop with unlimited items

Firstly, you've got to be sure that you've the ChestShop.admin permission / you are an OP. To make an Admin Shop, simply put "Admin Shop" (configurable in config.yml) on the first line of the sign.

Help with ChestShop's translation

ChestShop needs your help! We're switching to a new localisation system and we need your hand to help us translate the plugin. Help us translate the plugin!

Here is a list of player-made translations: Translation list

Permission nodes

Description
ChestShop.shop.*shop creation and buying/selling - it contains:
ChestShop.shop.create.*create all types of shops
ChestShop.shop.buybuy any item from shop
ChestShop.shop.sellsell any item to shop
ChestShop.modopen any shop chest, destroy stores
ChestShop.adminopen any shop chest, destroy stores, create admin shops

A full list of permission nodes

Useful tips by players

How not to get bankruptA customisable price table

Full plugin description

For full plugin description, visit the plugin's thread on Bukkit forums.

Got an error or suggestion?

Simply submit a ticket here!

Has ChestShop helped you or your server?

If you want to thank the team in a more materialistic way, feel free to donate! :)

Donate

A shout-out to my friend

I believe that the music he makes is really stunning - you can decide it for yourself!

His SoundCloud account

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of erik1988 erik1988 Apr 24, 2014 at 10:21 UTC - 0 likes

    I tried to deny players from buying maps by giving them "-chestshop.shop.buy.358" but they can still buy from regular- and adminshops.

    I alos tried to give them "-chestshop.shop.buy.*" but they are still able to buy.

    However when I gave them "-chestshop.shop.*" or "-chestshop.shop.buy" they were not able to buy.

    I use 3.7.8 with newest version of pex and latest spigot dev build. They dont have any "postive" chestshop permissions.

  • Avatar of Acrobot Acrobot Apr 23, 2014 at 19:24 UTC - 0 likes

    @LordKainzo: Go If you mean Admin Shops, please try updating to the LATEST version of Spigot and deleting plugins/ChestShop/users.db

    @KevinEssence: Go Sometimes it seems like the users.db file can corrupt if you've run an earlier version of Spigot. Please try downloading the latest version of Spigot again and delete plugins/ChestShop/users.db

    @_Snoogles_: Go As I replied above, try running the latest version of Spigot and ChestShop, making sure that plugins/ChestShop/users.db is deleted after the update.

    @Gaurav1234: Go You can already download the latest, dev version, that works with UUIDs. How it works is once a player joins the server, his username is mapped to an UUID. Then, all the signs are using his name (even if he changes it), which is assigned to the UUID. That's also why I require that players have to join the server at least once after the update for their shops to work.

  • Avatar of junk72385 junk72385 Apr 23, 2014 at 05:50 UTC - 0 likes

    how does this work with lockette nvm derp

    Last edited Apr 23, 2014 by junk72385
  • Avatar of Gaurav1234 Gaurav1234 Apr 23, 2014 at 01:54 UTC - 0 likes

    Hey, How is this plugin going to work with the 1.8 UUID update?

    Thanks! Gaurav

  • Avatar of _Snoogles_ _Snoogles_ Apr 22, 2014 at 23:28 UTC - 0 likes

    @Acrobot: Go

    Okay here is the irony. If i use spigot 1387 and

    I am still trying to get a version of chestshop past that to work with spigot ver 1387

    Last edited Apr 22, 2014 by _Snoogles_
  • Avatar of KevinEssence KevinEssence Apr 22, 2014 at 21:27 UTC - 0 likes

    @Acrobot: Go

    Latest Spigot and Chest Shop version.

    KevinEssence Server owner at hub.prxcraft.com

    Kevin

  • Avatar of LordKainzo LordKainzo Apr 22, 2014 at 18:47 UTC - 0 likes

    @Acrobot: Go

    Latest dev build has issues with the "server shop"

    For some reason "Exchange" isnt working for players - how do we force this to work?

  • Avatar of Rexwer Rexwer Apr 21, 2014 at 18:46 UTC - 0 likes

    Awesome plugin and Epic Dev! Very helpful!

  • Avatar of Acrobot Acrobot Apr 21, 2014 at 09:37 UTC - 0 likes

    @TheChosenOne0113: Go Unfortunately, I will be forced to make you update your plugins, due to the fact that as soon as the exploit became known to me, I fixed it. On 1st April.

    @_Snoogles_: Go I cannot reproduce that behaviour. Which ChestShop version are you running?

  • Avatar of MinecraftAdmin MinecraftAdmin Apr 21, 2014 at 03:49 UTC - 0 likes

    @TheChosenOne0113: Go What version are you running? The issue was fixed in v3.7.8

    IP: play.blockville.net - Come join our large survival community.

Facts

Date created
Aug 25, 2011
Categories
Last update
Apr 01, 2014
Development stage
Mature
Language
  • deDE
  • enUS
  • esES
  • frFR
  • itIT
  • plPL
  • ptBR
  • ruRU
  • zhCN
  • zhTW
License
GNU Lesser General Public License version 2.1 (LGPLv2.1)
Curse link
ChestShop (iConomyChestShop)
Downloads
3,097,859
Recent files
  • R: v3.7.8 for CB 1.7.2-R0.3 Apr 01, 2014
  • R: v3.7.7 for CB 1.7.2-R0.3 Mar 20, 2014
  • R: v3.7.6 for CB 1.7.2-R0.3 Mar 14, 2014
  • R: v3.7.5 for CB 1.7.2-R0.2 Feb 10, 2014
  • R: v3.7.3 for CB 1.7.2-R0.2 Jan 07, 2014

Authors

Relationships

Optional dependency
Lockette
LWC
Towny Advanced
Vault
WorldGuard