Campfire

Campfire - PvP Protection

About

Campfire is a PvP Protection plugin designed to give new players a chance to get their footing before being attacked by more well-equipped players. While under PvP Protection, players can't deal or receive PvP damage. Players' PvP protection expires after a configurable amount of time, or players may opt to terminate their protection early.

Campfire does protect against any kind of environmental damage such as mobs, fall damage, and drowning.

Features

  • Prevent new players from taking PvP damage from other players including swords, fists, arrows, anvils, tnt, and potions
  • Optionally prevent players from placing fire and lava too close to protected players
  • Optionally pause the protection count-down while in WorldGuard protected areas
  • Check the protection time each player has left
  • Immunity permissions to bypass protection checks

Options

The following options are available in the config.yml file:

  • Duration (integer)
    The length of time players' PvP protection will last in seconds

  • ResetOnDeath (boolean)
    Whether the players' protection starts over if they die.

  • WorldGuardPause (boolean)
    Pause the protection count-down when the player is in a WorldGuard region that has the AntiPvP flag or Invincible flag

  • FireRadius (integer)
    Radius in blocks players are not allowed to start fires or place lava near protected players.
    This prevents indirect killing from fires or lava. Set to 0 to disable.

Dependencies

  • WorldGuard (optional)
  • WorldEdit (optional)

Permissions

  • campfire.immune - Grants immunity to Campfire.
    Players with this permission will not be protected, and can attack those who are protected.
  • campfire.reset - Allows player to use the reset command.
    Players with this permission can reset other players' protection status.
  • campfire.reload - Allows player to use the reload command.
    Players with this permission can reload the plugin.

Github

This project is also available on Github. While major releases will be uploaded here on BukkitDev, you can get the latest development branch from this project's Github page, located at https://github.com/bitdagger/campfire

Note

This version is incompatible with the previous version released by Psychobit.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of strangeon_net strangeon_net Jul 22, 2013 at 16:06 UTC - 0 likes

    will this plugin be updated for 1.6.2 anytime soon? thanks!

  • Avatar of WASasquatch WASasquatch Jun 28, 2013 at 00:17 UTC - 0 likes

    Any news on development for 1.5.2 and 1.6.x?

  • Avatar of Chadwiko Chadwiko Jun 01, 2013 at 14:18 UTC - 0 likes

    @someonexh: Go

    Yes, and the plugin was causing memory leaks on the server.

  • Avatar of someonexh someonexh May 13, 2013 at 00:16 UTC - 0 likes

    @bitdagger: Go

    Please let me know. I have removed the plugin for now and am really looking to use it again when it doesn't have the spam issue.

    http://i47.tinypic.com/wgqc5j.jpg

  • Avatar of bitdagger bitdagger Apr 28, 2013 at 06:16 UTC - 0 likes

    I'll check out the spam issue and update the version number soon, as well as add an option for disallowing chests.

    @Nyr0n it's certainly possible to implement this behavior, but it's not something I'm prepared to do at this time. The sourcecode is available for free on Github, so if you can find someone willing to do it, they can fork it and make the changes for you.

  • Avatar of fichita fichita Apr 22, 2013 at 23:36 UTC - 0 likes

    I need this plugin let protected players open their chests and furnaces !!!!!

    Please add that as option: OPEN CHEST WHILE PROTECTED: TRUE/FALSE or something like that !!!!

    I really need thsi pluggin to stop the new players rage from my server due to abuse from older players

    https://www.serverminer.com/manage/index.php?r=status/1688.png

  • Avatar of Nyr0n Nyr0n Apr 19, 2013 at 12:45 UTC - 0 likes

    Hello this plugin is very useful... But I have a one question, is it possible to connect this to another plugin called ranks. For example there is someone in the rank of a "nomad" they are protected not unless the have leveled up to a higher rank "GuildsMan".

  • Avatar of PickleBumps PickleBumps Apr 19, 2013 at 03:43 UTC - 0 likes

    @someonexh: Go

    I'm having that problem too.

  • Avatar of someonexh someonexh Apr 17, 2013 at 11:48 UTC - 0 likes

    FYI. Doing a /version campfire still says v4.0

    I am having an issue that once in a while it will completely spam a new player when they join with PVP protection will expire in 15 minutes..

    Has anyone else had this issue with someone complaining about that?

  • Avatar of bitdagger bitdagger Mar 17, 2013 at 09:14 UTC - 0 likes

    Updated for 1.5, disallowed protected players from using hoppers, and a few other optimizations. Just waiting for the file to be approved.

    Last edited Mar 17, 2013 by bitdagger

Facts

Date created
Feb 09, 2013
Categories
Last update
Mar 18, 2013
Development stage
Release
Language
  • enUS
License
MIT License
Curse link
Campfire
Downloads
1,647
Recent files

Authors