iSafe

This project is abandoned.

Whether this project is out of date or its author marked it as abandoned, this project is no longer maintained.

If you wish to take this project over, please report it and state your intentions.

iSafe logo

iSafe - An assortment of beneficial features



Description ==

In iSafe, I concentrate on the way server Administrators are situated when managing their server, such as myself. Personally, I never feel I have all of the features I want, or need... maybe you do as well? I created iSafe to help resolve those problems. iSafe provides you, as a server Administrator, with many of those useful features that never seem to be around when needed.




Quote from iSafe:

iSafe gif




Features ==

  • 12 Different multiworld blacklists, with serveral toggable penalities & other administrive settings. Improved!
  • User files manager.
  • Auto update checker.
  • Multiple configuration files.
  • Permissions support.
    • Supports Vault and superperms. (You don't need Vault installed)
  • Security & simple AntiCheat settings.
  • IP Management settings.
  • Various fire related settings.
  • Enchantment settings.
  • Furnace & Weather settings.
  • World & TreeGrowth settings.
  • Explosion settings.
  • Flow & Piston settings.
  • BlockPhysics & BlockFade settings.
  • ForceDrop & Bucket settings.
  • Movement settings.
  • Gamemode settings.
  • Teleport & Chat settings.
  • Voidfall settings.
  • Damage & HealthRegeneration settings.
  • CreatureTarget settings.
  • Prevent invisibility potion usage.
  • Various creature settings, such as disabling endermen griefing, prevent zombies from breaking doors etc ..
  • Disable crop trampling for both mobs & players individually.
  • Handle what colors sheeps can grow their wool of.
  • Combustion settings.
  • MobSpawn blacklist for various reasons, such as spawer egg, natural etc ..
  • Alter the messages sent out by iSafe!
  • Full debug mode. (Currently under development.)
  • Mostly everything iSafe does is configurable.



Other ==


Downloads | Forum thread | Source | Tickets | First time tut

iSafe metrics

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Ebins Ebins Dec 04, 2013 at 02:39 UTC - 1 like

    I'm very sad that this became inactive :( Was a great plugin in its day. I wish someone else would take it over if the author won't work on it any longer.

    Solarius Minecraft Server

  • Avatar of skyblue10298 skyblue10298 Jun 28, 2013 at 16:50 UTC - 0 likes

    wow!

  • Avatar of Sotlol1 Sotlol1 May 04, 2013 at 09:48 UTC - 0 likes

    I got a little problem on my server after i installed isafe people need a light source to mine. Is there anyway i can fix it or change it?

  • Avatar of mrmag518 mrmag518 Apr 16, 2013 at 15:48 UTC - 0 likes

    @Vexelius: Go

    It's Java, please look-up a tutorial on how to solve it.

    BFAK:108733,02ba6071071a99be2ac2988429c2fab3147979c0c4ee1291dd22204cf9352a24

  • Avatar of Vexelius Vexelius Apr 16, 2013 at 15:15 UTC - 0 likes

    @mrmag518: Go

    I Downloaded the Java from the link you gave me.

    I'm still getting the same error... would there be another cause?

    EDIT : FINALLY SOLVED I found out that java version 6 was installed with 7. I removed the 6 files and downloaded 7 again. It works perfectly

    Last edited Apr 16, 2013 by Vexelius
  • Avatar of mrmag518 mrmag518 Apr 15, 2013 at 15:45 UTC - 0 likes

    @Vexelius: Go

    You're still not using the correct Java version..

    (Also sorry, I meant Java 7, not JDK 1.7)

    http://www.java.com/en/download/windows_xpi.jsp?locale=en

    Last edited Apr 15, 2013 by mrmag518
  • Avatar of Vexelius Vexelius Apr 15, 2013 at 15:15 UTC - 0 likes

    @mrmag518: Go

    Oh, I didn't even know what a JDK was. Thx for the info, I'll test it after I update it

    EDIT: Still Having an error

    00:31:51 [심각] Could not load 'plugins\iSafe.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError : com/mrmag518/iSafe/iSafe : Unsupported major.minor version 51.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:184) at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager. java:305) at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager .java:230) at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugins(CraftServer.ja va:239) at org.bukkit.craftbukkit.v1_5_R2.CraftServer.<init>(CraftServer.java:21 7) at net.minecraft.server.v1_5_R2.PlayerList.<init>(PlayerList.java:55) at net.minecraft.server.v1_5_R2.DedicatedPlayerList.<init>(SourceFile:11 ) at net.minecraft.server.v1_5_R2.DedicatedServer.init(DedicatedServer.jav a:105) at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java :381) at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:5 73) Caused by: java.lang.UnsupportedClassVersionError: com/mrmag518/iSafe/iSafe : Un supported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(Unknown Source) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$000(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader .java:80) at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader. java:53) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Unknown Source) at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:173) ... 9 more

    Last edited Apr 15, 2013 by Vexelius
  • Avatar of mrmag518 mrmag518 Apr 14, 2013 at 16:51 UTC - 0 likes

    @Vexelius: Go

    Ahhhhh, you should have given me this long time ago =)

    iSafe only works with JDK 1.7 and above.

  • Avatar of Vexelius Vexelius Apr 14, 2013 at 14:45 UTC - 0 likes

    found the error message

    23:43:31 [심각] Could not load 'plugins\iSafe.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError : com/mrmag518/iSafe/iSafe : Unsupported major.minor version 51.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:184) at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager. java:305) at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager .java:230) at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugins(CraftServer.ja va:239) at org.bukkit.craftbukkit.v1_5_R2.CraftServer.<init>(CraftServer.java:21 7) at net.minecraft.server.v1_5_R2.PlayerList.<init>(PlayerList.java:55) at net.minecraft.server.v1_5_R2.DedicatedPlayerList.<init>(SourceFile:11 ) at net.minecraft.server.v1_5_R2.DedicatedServer.init(DedicatedServer.jav a:105) at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java :381) at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:5 73) Caused by: java.lang.UnsupportedClassVersionError: com/mrmag518/iSafe/iSafe : Un supported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(Unknown Source) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$000(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader .java:80) at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader. java:53) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Unknown Source) at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:173) ... 9 more

    Just so you know, I tested the bukkits between 1.5.1 - R0.1 ~ 1.5.1 - R0.3

    Last edited Apr 14, 2013 by Vexelius
  • Avatar of Vexelius Vexelius Apr 14, 2013 at 14:41 UTC - 0 likes

    @mrmag518: Go

    I think the software you're talking about is pail. It isn't a downloading program, it's actually a plugin that changes the "looks" of the minecraft server console system

    Well anyways, pail isn't working with the new bukkit so i deleted it. Then I tried downloading iSafe with both Chrome and IE. The result was the same.

    The plugin wouldn't show up on the /pl list. I tried using Only the iSafe plugin. Still didn't work. I'll test everything I can. Just tell me what you need to test, and I'll tell you the results next weekend

Facts

Date created
Oct 06, 2011
Categories
Last update
Apr 12, 2013
Development stage
Abandoned
Language
  • enUS
License
GNU General Public License version 3 (GPLv3)
Downloads
56,578
Recent files

Authors