Backpack

19 - unable to upgrade or use hotkeys

What steps will reproduce the problem? really this is just what I did... don't know if it will reproduce or not.
1.installed spout on my server.  Already had - BbySpawner, dynmap,Essentials, EssentialsAntiBuild,EssentialsChat, EssentialsGroupBridge,EssentialsGroupManager, EssentialsProject, EssentialsSpawn, vault - installed
2.installed Backpack
3.changed permissions

What is the expected output? What do you see instead?
I expected to have a 9 slot backpack with hotkeys and upgrade ability

I got a 9 slot backpack and no hotkeys nor the ability to upgrade

What version of the product are you using?
backpack-b126

Do you have an error log of what happened?
no errors occured.  each stated that they had loaded and hooked:
2013-01-23 11:48:09 [INFO] [Backpack] Enabling Backpack vUnknown
2013-01-23 11:48:09 [INFO] [Backpack] Successfully hooked into Vault for economy transactions
2013-01-23 11:48:09 [INFO] [Backpack] Successfully hooked into Vault for permissions
2013-01-23 11:48:09 [INFO] [Backpack] Successfully hooked into SpoutPlugin for keybindings
2013-01-23 11:48:09 [INFO] [SpoutPlugin] Initializing precache for Backpack

Please provide any additional information below.

I'm not sure what I missed, thanks for the help.

User When Change
dockter Jan 24, 2013 at 16:34 UTC
dockter Jan 24, 2013 at 16:34 UTC
RagginMAMA Jan 24, 2013 at 15:43 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 6 comments
  • Avatar of Fendelgast Fendelgast Feb 17, 2013 at 02:49 UTC - 0 likes

    I just tested with spoutcraft, and it works just fine, I was just expecting the mod to work from commandline if I disable spout support does that enable command line ? I have no problem forcing my users to use spoutcraft, just trying to understand.

  • Avatar of Fendelgast Fendelgast Feb 17, 2013 at 02:36 UTC - 0 likes

    Sorry for the delay, is /backpack upgrade only supported in Spout If so I must have misread that, I will test again

  • Avatar of dockter dockter Feb 13, 2013 at 14:50 UTC - 0 likes

    Are your users using Spoutcraft client? This is the only way to make the hotkeys work along with the GUI upgrade screen.

    Please confirm.

    BFAK:90572240,474344991705deee14d355de6ad5b26280465c85414dd9c8d4e607e5e6e3f34e

  • Avatar of Fendelgast Fendelgast Feb 10, 2013 at 05:32 UTC - 0 likes

    I am also experiencing this problem, I have not been able to take down the server to remove all but backpack and bperm to verify it works that way or not, using bpermissions to manage permissions

    groups:
    member:
    permissions:
    - backpack.keepitems
    - backpack.overflow
    - backpack.size.18
    - backpack.size.27
    - backpack.size.36
    - backpack.size.45
    - backpack.size.54
    - backpack.upgrade
    - backpack.use
    - lagmeter.command.lag
    - machinadrill.*
    - towny.wild.*
    groups:
    - visitor

    2013-02-09 23:19:26 [INFO] [Vault] Enabling Vault v1.2.22-b277
    2013-02-09 23:19:26 [INFO] [Vault][Economy] Gringotts hooked.
    2013-02-09 23:19:26 [INFO] [Vault][Economy] Gringotts found: Loaded
    2013-02-09 23:19:26 [INFO] [Vault][Permission] bPermissions2 hooked.
    2013-02-09 23:19:26 [INFO] [Vault][Permission] bPermissions 2 found: Loaded
    2013-02-09 23:19:26 [INFO] [Vault][Permission] SuperPermissions loaded as backup permission system.
    2013-02-09 23:19:26 [INFO] [Vault][Chat] bPermissions2 hooked.
    2013-02-09 23:19:26 [INFO] [Vault][Chat] bPermssions2 found: Loaded
    2013-02-09 23:19:26 [INFO] [Vault] Enabled Version 1.2.22-b277
    2013-02-09 23:19:26 [INFO] [SpoutPlugin] Initializing precache for Vault
    ...
    2013-02-09 23:19:38 [INFO] [Backpack] Enabling Backpack vUnknown
    2013-02-09 23:19:38 [INFO] [Backpack] Successfully hooked into Vault for economy transactions
    2013-02-09 23:19:38 [INFO] [Backpack] Successfully hooked into Vault for permissions
    2013-02-09 23:19:38 [INFO] [Backpack] Successfully hooked into SpoutPlugin for keybindings
    2013-02-09 23:19:38 [INFO] [SpoutPlugin] Initializing precache for Backpack

    2013-02-09 23:20:37 [INFO] Sentilnal issued server command: /backpack
    2013-02-09 23:20:45 [INFO] Sentilnal issued server command: /backpack upgrade
    2013-02-09 23:20:50 [INFO] Sentilnal issued server command: /backpack
    2013-02-09 23:20:53 [INFO] Sentilnal issued server command: /money
    2013-02-09 23:23:29 [INFO] Sentilnal issued server command: /backpack
    2013-02-09 23:23:35 [INFO] Sentilnal issued server command: /backpack upgrade

    Last edited Feb 10, 2013 by Fendelgast
  • Avatar of RagginMAMA RagginMAMA Jan 24, 2013 at 17:31 UTC - 0 likes

    <<reply 1216084>>
    for my "builders" I added these:
        - backpack.use
        - backpack.upgrade
        - backpack.keepitems
        - backpack.overflow
        - backpack.size.18
        - backpack.size.27
        - backpack.size.36
        - backpack.size.45
        - backpack.size.54

    for my mods/admins:
          - backpack.use
          - backpack.upgrade
          - backpack.keepitems
          - backpack.overflow
          - backpack.size.18
          - backpack.size.27
          - backpack.size.36
          - backpack.size.45
          - backpack.size.54
          - backpack.admin

    I am using GroupManager

    Last edited Jan 24, 2013 by RagginMAMA
  • Avatar of dockter dockter Jan 24, 2013 at 16:34 UTC - 0 likes

    Did you assign the correct permissions?

  • 6 comments

Facts

Last updated
Feb 10, 2013
Reported
Jan 24, 2013
Status
Replied - Someone has replied after waiting for more information.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees