AutoAnnouncer - Global announcements every few minutes

Latest Version: v1.7-03.23

Tested with CB: 1.2.5-R5.0-SNAPSHOT, 1.2.5-R4.0-SNAPSHOT, 1.2.5-R3.0-SNAPSHOT, 1.2.5-R2.0-SNAPSHOT, 1.2.5-R1.0-SNAPSHOT

You need Vault for permissions and groups support:

VAULT IS NOT REQUIRED, If you don't want use Vault for permissions and group support set the follow options in config.yml:

  • Permission: false

If you do this, only OPs can use the commands


  • /announcer help|? - Show help
  • /announcer on|off - Start/stop AutoAnnouncer
  • /announcer restart - Restart the AutoAnnouncer scheduler
  • /announcer interval <minutes|seconds> - Set interval time between announcements
  • /announcer random <on|off> - Set random or use consecutive announcements
  • /announcer add [announce here] - Add a new announce to the list
  • /announcer list - List all the announces with the id.
  • /announcer remove [announce id] - Remove a announce from the list.

    Default Settings.yml

Formats and color codes supported:

Color ExampleShort CodeLong CodeExampleResult

Multiline feature:


Permissions Node:

If permission not found or not used only OP can use the commands.
For all command:



  • Interval time adjustable. Minutes or seconds.
  • Random/Consecutive setting.
  • Colors support.
  • Format support.
  • Add, remove, list commands.
  • On/Off AutoAnnouncer.
  • Commands in-game.
  • Permissions support.
  • > All permissions supported by Vault.
  • Permissions groups support.
  • Editable Tag.
  • YAML settings.




READ THE POST!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!111111111

Check your config.yml syntax first after reply:

Read the YAML rules:


USE THIS ==> or I kick your ass!!!!!!!!!!11111111111


I do this in my free time, so if you like my work, I'd be completely grateful for any donation you can send me. With this I pay the server where store my files and project. These donations motivate me to continue adding features and keep it free for all.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of yellowwinner yellowwinner Sep 23, 2015 at 12:55 UTC - 1 like

    For confirmation this plugin works great with Spigot 1.8 with no config needed to be changed. :D

  • Avatar of Pr0totype2 Pr0totype2 Jun 20, 2015 at 14:50 UTC - 0 likes

    @Carson1st: Go

    May I see the .yml file please?

  • Avatar of Carson1st Carson1st May 20, 2015 at 01:13 UTC - 0 likes

    Someone help please, when I add a new line to the announcer it says thiers not any brodacast messages?

  • Avatar of buzzsaw100 buzzsaw100 Apr 26, 2015 at 03:45 UTC - 0 likes

    Plugin still working great in spigot 1.8, works perfectly still :)

  • Avatar of HiddenAether HiddenAether Jan 04, 2015 at 00:37 UTC - 0 likes

    @ShadowCrafter829: Go

    You have too be careful with decompiled plugins unless you have the legitimate raw code. Otherwise when a plugin is compiled there is code added into the plugin class files that has been executed by the compiler.

    If you would like a custom designed website message me on skype @ HiddenAether

  • Avatar of ShadowCrafter829 ShadowCrafter829 Dec 05, 2014 at 20:59 UTC - 0 likes

    Never mind my update is successful. I am just testing it and fixing bugs.

    Owner and developer of ShadowCraft!

  • Avatar of ShadowCrafter829 ShadowCrafter829 Dec 05, 2014 at 20:39 UTC - 0 likes

    I am attempting to update this plugin to Spigot-1.8, but am unable to figure out what "Announcer.access$108" and "Announcer.access$102" mean. I am fairly new to java so I don't know old code (Which I am assuming this is). If anybody can help, I would really appreciate, for I love this plugin and I want it to live beyond its current compatibility.

  • Avatar of killertunes killertunes Aug 05, 2014 at 22:21 UTC - 1 like

    Running this on CraftBukkit version git-Bukkit-1.7.9-R0.2 with no problems. Great plugin!

  • Avatar of buzzsaw100 buzzsaw100 Jul 03, 2014 at 00:17 UTC - 1 like

    Great plugin, still holding up great after these years :)

  • Avatar of StakeoutPunch StakeoutPunch Apr 28, 2014 at 23:51 UTC - 0 likes

    @blueheadedtiger_: Go This plugin works on 1.7.2-1.7.5. I have not tested any versions past 1.7.5, but it will probably work as all it really does is insert text into the chat occasionally.


Date created
Mar 03, 2012
Last update
Mar 23, 2012
Development stage
  • enUS
Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
Curse link
Recent files



Required dependency