AntiCreeper

28 - Config issues

What steps will reproduce the problem?
Like I commented, when using the     acs creeper yield 100 acb creeper damageblocks true commands in the example commands, creepers still damage blocks as normal. I tried changing the depth to 0 like you suggested, but this made it that EVERY block was destroyed that the explosion effected.

Please attach your config.yml file. Do the names listed under nerfed_worlds exactly match your server's world names?
I run two worlds on the server, 'EXcraft' and 'creative, I have gone to both, turned on AC and issued the commands.

What is the expected output? What do you see instead?

What versions of AntiCreeper and of Bukkit are you using?
 AntiCreeper 4.5 for CB 1.4.6-R0.1,  craftbukkit-1.4.6-R0.4

Do you have an error log of what happened?

Name Description Size MD5
config.yml Config YML 1.4 KiB dda7b8ba94f5...
User When Change
filbert66 Feb 01, 2013 at 21:11 UTC
filbert66 Jan 31, 2013 at 00:57 UTC
filbert66 Jan 31, 2013 at 00:51 UTC
bgernert Jan 29, 2013 at 20:07 UTC
filbert66 Jan 15, 2013 at 02:45 UTC
filbert66 Jan 15, 2013 at 02:14 UTC Changed assigned to from Rothens to filbert66
Kisurahara Jan 13, 2013 at 14:59 UTC

Added attachment config.yml

Kisurahara Jan 13, 2013 at 14:58 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 9 comments
  • Avatar of bgernert bgernert Feb 01, 2013 at 17:37 UTC - 0 likes

    @filbert66: Go

    Hello filbert66,

    before I saw your post I already updated my server to the new craftbukkit version 1.4.7-R1.0.

    AntiCreeper is now working! Maybe there was a bug in the last beta build or a conflict with some other plugin, I don't know but I am happy that everything is now working!

    Thank you for your help!

    • Unbenannt.PNG
      ac world && ac world on
  • Avatar of filbert66 filbert66 Jan 31, 2013 at 19:39 UTC - 0 likes

    @bgernert: Go

    Please try these commands in-game first, then repeat your tests:

    ac world
    ac world on
    

    My plugins: Anticreeper, AntiFire, BedCheck, Thor, Unbreakable Items, Enchantment Limiter. Contributor: Tree-Assist

    BFAK:67982,3d6540176e18ca75f0a204a87213d75a51e4b745f16c619b8fcef59ccfeab5cb

  • Avatar of bgernert bgernert Jan 31, 2013 at 09:29 UTC - 0 likes

    Hi filbert66,

    I tried now any possible combination:

    • acb creeper damageblocks true
    • acb creeper damageblocks false
    • acb creeper explodeblocks true
    • acb creeper explodeblocks false

    In all cases a creeper explosion still destroys blocks.

    But I saw a funny side effect if I do a "ac save" and "ac reload". If I hit a creeper after the reload, the creeper "flies" away from me. I need to restart my client to get the creeper back to the normal behavior.

  • Avatar of filbert66 filbert66 Jan 31, 2013 at 01:03 UTC - 0 likes

    I just confirmed that the command "acs creeper yield " does not work, unless you then do a "ac save" and "ac reload".

    Please set yield via your config file until next version is out.

  • Avatar of filbert66 filbert66 Jan 31, 2013 at 00:51 UTC - 0 likes

    @bgernert: Go

    Thanks for the details. I still cannot duplicate it, but another user has reported a similar issue. In your first comments you say that you issued command "acb creeper damageblocks true" but your config uses "explodeblocks" syntax. That's not supposed to cause a problem, but perhaps if you use "explodeblocks" instead?

    I tried changing the depth to 0 like you suggested, but this made it that EVERY block was destroyed that the explosion effected.

    This is very odd behavior and appears to indicate that you have a skipped line in your config file. Did you set depth via config.yml or using commands?

  • Avatar of bgernert bgernert Jan 30, 2013 at 08:53 UTC - 0 likes

    I have added my configuration file to my last comment. I have edited the config file by hand.

    "java -version" gives me:

    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
    
    • acp.jpg
      acp creeper
  • Avatar of filbert66 filbert66 Jan 29, 2013 at 21:51 UTC - 0 likes

    @bgernert: Go

    Please post your config.yml, or list the sequence of commands you use, then issue "acp creeper" and post the result or "ac save" and post the resulting config.yml. What version of Java?

    Last edited Jan 29, 2013 by filbert66: allow for acp
  • Avatar of bgernert bgernert Jan 29, 2013 at 20:07 UTC - 0 likes

    Hi,

    I have got the same problem like Kisurahara. If a creeper explodes, it still destroys land (explodeblocks is set to false)

    Other plugins on my server:

    • PermissionsEX
    • PTweeks
    • SimpleChestLock
    • WorldBorder

    I am using craftbukkit version 1.4.7 R0.1

    Name Description Size MD5
    config.yml My config file 2.4 KiB 5edbc69fe748...
  • Avatar of filbert66 filbert66 Jan 15, 2013 at 02:44 UTC - 0 likes

    Cannot duplicate problem.

    Loaded your config file without edit (it also includes world "world" as I use) and creepers didn't destroy blocks. Executed the commands as you have them above and it works as expected. I was able to fill in the holes with exactly the blocks that I picked up. Even downloaded latest dev build craftbukkit-1.4.6-R0.4- (build 2594) and still works.

    There must be something else happening. Try unloading any other plugins you have, especially any that modify or limit explosions. Also, are you perhaps running Java 7? Someone else reported another plugin of mine not working when they use JRE 1.7.

    Last edited Jan 15, 2013 by filbert66: added Java query
  • 9 comments

Facts

Last updated
Feb 01, 2013
Reported
Jan 13, 2013
Status
Invalid - This was not a valid report.
Type
Other - Some other kind of issue
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees