AntiCommandTab

Header

http://i.imgur.com/xmrn6je.png http://i.imgur.com/K82aaGv.png http://i.imgur.com/zPLjtR2.png

Description

AntiCommandTab protects your server from Layer 1 CoPY-Cat attacks. Users will not be able to figure out your server plugins and through commands or [TAB].

Features

  • Blocks / [TAB]
  • Blocks /ver [TAB]
  • Blocks /version [TAB]
  • Blocks /about [TAB]
  • Blocks /pl and /plugins
  • Blocks /about
  • Blocks /version and /ver
  • Blocks /?
  • In the config.yml you can customize the deny message (chat format supported!)

Permissions

  • lib.commandtab.bypass - bypasses /[TAB] and commands

Requirements

  • This plugin requires ProtocolLib.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of rubenowen12 rubenowen12 Apr 17, 2014 at 23:23 UTC - 0 likes

    @sgtcaze: Go

    sgtcaze, he is correct. Not all servers have it, because some have custom bukkit builds.

    On most servers, or to bypass the restrictions you can do the following: /bukkit:pl /bukkit:plugins /bukkit:?

    Please fix this! - Ruben

    RubenzRaidz

  • Avatar of sgtcaze sgtcaze Apr 17, 2014 at 07:46 UTC - 0 likes

    @pilvimaa: Go

    Just tried it on a server, it says "Unknown command". Have you tested and confirmed this?

    Join my server: playmc.cc | Jenkins | Website | YouTube | Twitter The Cosmos Cloud

  • Avatar of pilvimaa pilvimaa Apr 17, 2014 at 07:24 UTC - 0 likes

    Apparently you can use /bukkit::?, /bukkit::help and /bukkit:plugins to get around the restrictions.

  • Avatar of Robson112011 Robson112011 Mar 04, 2014 at 16:53 UTC - 0 likes

    Version for 1.5.2 working?

    ArtCraft seu servidor de minecraft!

  • Avatar of IPFaNbg IPFaNbg Feb 15, 2014 at 10:22 UTC - 0 likes

    Add java 6 support pls...

  • Avatar of GeekWithAChick GeekWithAChick Feb 13, 2014 at 17:50 UTC - 0 likes

    This is perfect

    Skript Fest

  • Avatar of sgtcaze sgtcaze Jan 01, 2014 at 02:11 UTC - 0 likes

    Version 3.4 uploaded with the following changes:

    • Now forces TabComplete message to lower case, resolving an (unreported but still abusable) bug.
    Last edited Jan 01, 2014 by sgtcaze
  • Avatar of sgtcaze sgtcaze Dec 11, 2013 at 16:48 UTC - 0 likes

    @Mcraftpete: Go

    There's the problem :) So the gist of it is, Version 3.2 supports 1.6.4 and ProtocolLib 2.7.3. Version 3.3 supports 1.7.2 and ProtocolLib 3.0. You can find development builds (of ProtocolLib) on Aadnk's build server.

    Last edited Dec 11, 2013 by sgtcaze
  • Avatar of Mcraftpete Mcraftpete Dec 11, 2013 at 08:03 UTC - 0 likes

    Hi, I had made sure I was deopped and made myselef guest during this to ensure it was accurate and done on more then 1 of my servers. I am using protocollib-2.7.3 which I believe is the latest , maybe I should use earlier version ?

    Thanks, Pete

  • Avatar of sgtcaze sgtcaze Dec 11, 2013 at 06:36 UTC - 0 likes

    @Mcraftpete: Go

    Might be the version of ProtocolLib you're using. Lots of things are shifting under Aadnk's codebase. If you can tell me which version you're using (either on bukkit or Jenkins) I can give it a go.

Facts

Date created
Nov 05, 2012
Category
Last update
Jan 01, 2014
Development stage
Mature
License
All Rights Reserved
Curse link
AntiCommandTab
Downloads
6,431
Recent files
  • R: v3.4 for CB 1.7.2-R0.2 Jan 01, 2014
  • R: v3.3 for 1.7.2 Dec 07, 2013
  • R: v3.2 for CB 1.6.4-R2.0 Nov 30, 2013
  • R: v3.1 for CB 1.6.4-R2.0 Nov 30, 2013
  • R: v3.0 for CB 1.6.4-R2.0 Nov 28, 2013

Authors

Relationships

Required dependency
ProtocolLib